Nachrichtenmodul Email

Themen aus älteren Betatests.
Offe
Beiträge: 568
Registriert: 30. Aug 2007, 17:42

Nachrichtenmodul Email

Beitragvon Offe » 10. Jan 2016, 19:49

Wenn ich eine Email über das Nachrichtenmodul an einzelne Empfänger oder an eine Rolle schicke, wird diese Email nicht an die Empfänger geschrieben. Es erscheint keinerlei Fehlermeldung. Einzig die Option "Kopie der E-Mail an mich senden" stellt auch die Kopie an mich zu.
Benutzeravatar
fasse
Administrator
Beiträge: 4805
Registriert: 12. Nov 2005, 16:06

Re: Nachrichtenmodul Email

Beitragvon fasse » 17. Jan 2016, 12:00

Hallo Offe,

probier es noch mal bitte aus. Auf der Spielwiese hat es gerade bei mir funktioniert. Evlt. ist es dann durch andere Fehlerbehebungen wieder funktionstüchtig geworden.

Viele Grüße
Fasse
Offe
Beiträge: 568
Registriert: 30. Aug 2007, 17:42

Re: Nachrichtenmodul Email

Beitragvon Offe » 17. Jan 2016, 13:17

Hallo fasse,

nach vielen Tests, konnte ich jetzt die Ursache finden. Es ist kein generelles Problem, sondern liegt an einer Spezialkonstellation:

- Testrolle hat in den Eigenschaften für die Option "E-Mails zusenden" den Wert "Nur Rollenmitglieder stehen"

- Adminuser ist nicht Mitglied der Testrolle

- Adminuser sieht auf der Seite "Email schreiben" die Testrolle als möglichen Empfänger, aber nicht die User, die nur Mitglied dieser Testrolle sind

- Adminuser kann Email an die Testrolle schreiben (mit Option Kopie senden")

- Kopie der Email wird dem Adminuser gesendet, es geht aber keine Email an die Rollenmitglieder raus, für den Admin sieht dies aber so aus

--> Testrolle darf als möglichen Empfänger für alle Nichtmitglieder dieser Rolle nicht auftauchen

Gruß Offe
weissst
Developer
Beiträge: 342
Registriert: 4. Nov 2011, 18:07
Wohnort: 54xx

Re: Nachrichtenmodul Email

Beitragvon weissst » 18. Jan 2016, 22:38

Hallo Fasse,

ich denke wir haben hier eine Unstimmigkeit, welche Rechte mehr kraft haben.
"E-Mails an alle Rollen schreiben" (rol_mail_to_all) oder "E-Mails zusenden" (rol_mail_this_role)
soweit ich das im code sehe, fragen wir einmal die erste ab und dann beim versand die zweite.

wie sollen wir das handhaben?

lg
Stefan
Benutzeravatar
fasse
Administrator
Beiträge: 4805
Registriert: 12. Nov 2005, 16:06

Re: Nachrichtenmodul Email

Beitragvon fasse » 18. Jan 2016, 23:28

Hi Stefan,

ich habe selber noch nicht in den Code geschaut, hatte mir aber nach Offes Hinweis schon mal Gedanken gemacht und vermutet, dass es in diese Richtung geht.

Ich schau mir das auch noch mal im Code an. Eigentlich sollte man eine Mail an die Rolle schreiben können, wenn man das Recht "Mail an alle Rollen" hat.

Viele Grüße
Markus
Benutzeravatar
fasse
Administrator
Beiträge: 4805
Registriert: 12. Nov 2005, 16:06

Re: Nachrichtenmodul Email

Beitragvon fasse » 26. Jan 2016, 22:14

Hi Offe,

ich bekomme das Szenario nicht nachgestellt.

Kannst du mal eine Rolle auf der Spielwiese so konfigurieren?

Viele Grüße
Fasse
Offe
Beiträge: 568
Registriert: 30. Aug 2007, 17:42

Re: Nachrichtenmodul Email

Beitragvon Offe » 27. Jan 2016, 10:52

Hallo fasse,

ich habe auf der Spielwiese das ganze nun mal nachgestellt:

- eine Rolle TestOffe mit entsprechender Konfiguration
- einen neuen User TestuserOffe (mit deiner Webmaster-Email von Admidio)
- TestuserOffe ist in der Rolle TestOffe
- Webmaster kann an Rolle TestOffe schreiben (siehe als erfolgreich gekennzeichnete Mail im Nachrichtenmodul)

Kannst du bitte prüfen, ob du die Email in deinem Webmaster-Email findest. Dies sollte nicht der Fall sein.

Bei dem Nachstellen ist mir ein weiterer Bug aufgefallen: Wenn in den Moduleinstellungen den Punkt "Email an Ehemalige senden" aktiviert hat, wird der TestuserOffe als ehemaliges Mitglied dargestellt, obwohl er gar nicht auftauchen darf.

Gerne können wir uns das Thema auch zusammen in meiner Installation anschauen.

Gruß Offe
Benutzeravatar
fasse
Administrator
Beiträge: 4805
Registriert: 12. Nov 2005, 16:06

Re: Nachrichtenmodul Email

Beitragvon fasse » 27. Jan 2016, 21:01

Hi Offe,

die Mail habe ich bekommen :?

Viele Grüße
Fasse
Offe
Beiträge: 568
Registriert: 30. Aug 2007, 17:42

Re: Nachrichtenmodul Email

Beitragvon Offe » 27. Jan 2016, 22:36

Hi fasse,

mir ist heute morgen beim Nachbauen dieser Konstellation ein Fehler unterlaufen, sodass ich diese Testrolle, bei der der Fehler aufgetreten ist gelöscht habe. Es musste irgendetwas mit der Option "Email senden nur von Rollenmitgliedern zu tun haben", aber nun geht es mir wie dir, ich bekomm es nicht mehr nachgebaut :( . Ich versuche die Tage es in irgendeiner Form wieder hinzubekommen.

Es bleibt aber noch in diesem Zusammenhang der andere beschriebene Bug, der auch in der Spielwiese zu sehen ist:

Bei dem Nachstellen ist mir ein weiterer Bug aufgefallen: Wenn in den Moduleinstellungen den Punkt "Email an Ehemalige senden" aktiviert hat, wird der TestuserOffe als ehemaliges Mitglied dargestellt, obwohl er gar nicht auftauchen darf.


Gruß Offe
Benutzeravatar
fasse
Administrator
Beiträge: 4805
Registriert: 12. Nov 2005, 16:06

Re: Nachrichtenmodul Email

Beitragvon fasse » 28. Jan 2016, 23:53

Offe hat geschrieben:Bei dem Nachstellen ist mir ein weiterer Bug aufgefallen: Wenn in den Moduleinstellungen den Punkt "Email an Ehemalige senden" aktiviert hat, wird der TestuserOffe als ehemaliges Mitglied dargestellt, obwohl er gar nicht auftauchen darf.

Der Fehler ist jetzt behoben.
Offe
Beiträge: 568
Registriert: 30. Aug 2007, 17:42

Re: Nachrichtenmodul Email

Beitragvon Offe » 30. Jan 2016, 18:14

Im Zusammenhang mit dem Punkt "Email an Ehemalige senden" muss ich nun nochmal genauer nachfragen:

Ich habe einen User der in einigen Rollen Mitglied ist (aktiv) und der ein Ehemaliger der Webmasterrolle ist. Wenn ich den Hacken "Email an Ehemalige senden" setze, wird der User im Emailformular unter "Ehemalige Mitglieder" aufgelistet. Wenn der Hacken "Email an Ehemalige senden" nicht gesetzt ist, wird der User im Emailformular unter "Aktive Mitglieder" aufgelistet.

Wie soll die Logik "Email an Ehemalige senden" genau funktionieren?
Benutzeravatar
fasse
Administrator
Beiträge: 4805
Registriert: 12. Nov 2005, 16:06

Re: Nachrichtenmodul Email

Beitragvon fasse » 31. Jan 2016, 17:41

Hallo Offe,

wenn Ehemalige aktiviert ist, dann sollen nur Benutzer als Ehemalige aufgelistet werden, die keine aktive Rolle haben, sondern halt nur Ehemalige sind.

Ich habe jetzt den Check noch einmal umgebaut. Bitte prüfe das noch mal genau. Ich hoffe keine neue Lücke aufgemacht zu haben ...

Viele Grüße
Fasse
Offe
Beiträge: 568
Registriert: 30. Aug 2007, 17:42

Re: Nachrichtenmodul Email

Beitragvon Offe » 31. Jan 2016, 22:22

Hi fasse,

danke dir für die Korrektur. Das Thema ist echt nicht einfach. Für den Webmaster mit allen Recht passt es nun. Im Userfeld gibt es noch eine Besonderheit:

- User1 ist Mitglied der Rolle 1, die in den Eigenschaften für die Option "Rollenmitgliedschaft sehen" den Wert "nur Rollenmitglieder" gesetzt hat

- User 1 ist kein Mtiglied einer weiteren Gruppe

- User 2 ist nicht Mitglied der Rolle 1

- User 2 sieht User 1 nun als ehemaliges Mitglied im Nachrichtenmodul, wenn die Option "Email an Ehemalige senden" aktiviert ist. Wenn die Option nicht aktiviert ist, sieht User2 User 1 nicht. So müsste es auch mit gesetzer Option sein. Wenn in Rolle 1 die Eigenschaft auf den Wert "Alle angemeldeten Benutzer" geändert wird, ist das Verhalten korrekt, da User 1 dann als aktiv gesehen wird.

--> Fehler liegt in der Kombination "Email an Ehemalige senden" mit "Rollenmitgliedschaft sehen - nur Rollenmitglieder" für User

Gruß Offe
Benutzeravatar
fasse
Administrator
Beiträge: 4805
Registriert: 12. Nov 2005, 16:06

Re: Nachrichtenmodul Email

Beitragvon fasse » 5. Feb 2016, 22:59

Hmm, das kann ich nicht bestätigen.

Bist du sicher, dass keine Rolle das Recht "alle listen" oder "alle Mitglieder" sehen oder so noch zusätzlich hat?
Offe
Beiträge: 568
Registriert: 30. Aug 2007, 17:42

Re: Nachrichtenmodul Email

Beitragvon Offe » 13. Feb 2016, 17:49

Da ich sehr viel getestet habe, kann ich es einfach nicht mehr reproduzieren bzw. so beschreiben, dass ich den Fehler finden kann. Ich würde sagen, wir sehen das Thema als gelöst an, es sind ja in diesem Thread schon mehrere Probleme beschrieben und gelöst worden.

Gruß Offe

Zurück zu „Betatests - Archiv“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast