Eigene Profilfelder werden nicht mehr angezeigt

Hast du einen Fehler in der aktuellen Version gefunden ? Diesen kannst du uns hier mitteilen und uns bei der Fehlersuche helfen.
Antworten
TurboXXL
Beiträge: 20
Registriert: 5. Sep 2017, 12:13

Eigene Profilfelder werden nicht mehr angezeigt

Beitrag von TurboXXL »

Hallo zusammen,

ich wurde von Mitgliedern aufmerksam gemacht, dass Profilfelder, die wir selbst angelegt haben, plötzlich im Profil nicht mehr angezeigt werden.

Darauf hin habe ich mir die Eigenschaften der Profilfelder angeschaut und gesehen, dass die Augen und Schlüssel sehr unregelmäßig ausgegraut oder schwarz sind. Das war vorher nicht so und ich bin der einzige Admin.

Selbst wenn ich alle Profilfelder gleich einrichte, werden als User nicht alle angezeigt. Sehr merkwürdig.

Aufgefallen ist mit auch, dass jetzt im Text gegendert wird.

Kann das eventuell mit einem Update zu tun haben?

Mit fällt gerade auf, dass ich noch 4.1.15 nutze. Ist das vielleicht mit 4.1.17 behoben? Ich teste es später...
TurboXXL
Beiträge: 20
Registriert: 5. Sep 2017, 12:13

Re: Eigene Profilfelder werden nicht mehr angezeigt

Beitrag von TurboXXL »

So.. Update auf 1.17 Problemlos durchgeführt, aber das Problem besteht weiterhin.

Jetzt bekomme ich einen Whitescreen, wenn ich ein Profilfeld als Admin bearbeiten möchte und es dann speichern will. Als Admin werden mir alle Profilfelder angezeigt, wenn ich mich als normals User anmelde und mein Profilfeld betrachten möchte, fehlen Profilfelder mitten drin.

Hier die Fehlermeldung, wenn der Debug-Modus aktiviert ist.

Fatal error: Uncaught Error: Class 'HTMLPurifier_Token_Empty' not found in /hp/cr/aa/uf/www/admidio/adm_program/libs/server/ezyang/htmlpurifier/library/HTMLPurifier/TokenFactory.php:50 Stack trace: #0 /hp/cr/aa/uf/www/admidio/adm_program/libs/server/ezyang/htmlpurifier/library/HTMLPurifier/Lexer/DOMLex.php(39): HTMLPurifier_TokenFactory->__construct() #1 /hp/cr/aa/uf/www/admidio/adm_program/libs/server/ezyang/htmlpurifier/library/HTMLPurifier/Lexer.php(117): HTMLPurifier_Lexer_DOMLex->__construct() #2 /hp/cr/aa/uf/www/admidio/adm_program/libs/server/ezyang/htmlpurifier/library/HTMLPurifier.php(153): HTMLPurifier_Lexer::create(Object(HTMLPurifier_Config)) #3 /hp/cr/aa/uf/www/admidio/adm_program/system/bootstrap/function.php(407): HTMLPurifier->purify('<p>Hier ist ent...') #4 /hp/cr/aa/uf/www/admidio/adm_program/modules/profile-fields/profile_fields_function.php(169): admFuncVariableIsValid(Array, 'usf_description', 'html') #5 {main} thrown in /hp/cr/aa/uf/www/admidio/adm_program/libs/server/ezyang/htmlpurifier/library/HTMLPurifier/TokenFactory.php on line 50

Leider kann ich das nicht zuordnen.

Es muss aber wieder gewährleistet sein, dass alle Profilfelder dem Mitglied angezeigt werden.

Wie schon erwähnt, ausser Updates wurden keine Veränderungen in den letzten 6 Monaten vorgenommen und früher wurde alles angezeigt.

Ich nutze noch PHP 7.4 aber auch unter 8.1 tritt der Fehler auf. Als Admin sehe ich

Für gute Ratschläge oder für Hinweise welche Infos ich noch zur Verfügung stellen soll, wäre ich sehr dankbar.

Gruss
Turbo :-)
Antworten