Fehler nach neuer PHP-Version

Hast du einen Fehler in der aktuellen Version gefunden ? Diesen kannst du uns hier mitteilen und uns bei der Fehlersuche helfen.
chrissy-dizzy
Beiträge: 102
Registriert: 24. Jun 2010, 17:35

Fehler nach neuer PHP-Version

Beitragvon chrissy-dizzy » 5. Jan 2019, 18:32

Hi,
ich habe beim Provider die php-Version auf 7.2 umgestellt für eine Admidio-Installation von 2012.
Dann kam folgende Fehlermeldung, die auch nicht verschwand nach Revision auf 5.6

Fatal error: Uncaught Error: Call to undefined function mysql_connect() in /homepages/35/dXXXXXX/htdocs/admidio/adm_program/system/db/mysql.php:24 Stack trace: #0 /homepages/35/dXXXXXXX/htdocs/admidio/adm_program/system/common.php(80): MySqlDB->connect('dbXXX.1und1.de', 'dboXXXXXX, 'XXXXXX', 'dbXXXXXX') #1 /homepages/35/dXXXXXX/htdocs/admidio/index.php(5): require_once('/homepages/35/d...') #2 {main} thrown in /homepages/35/dXXXXXX/htdocs/admidio/adm_program/system/db/mysql.php on line 24

Folgende Frage dazu:
Wie kann ich die alte Version wieder herstellen, um dann das Update auszuführen?
Oder muss ich anders vorgehen?

Danke für euern Support!
XimeX
Developer
Beiträge: 1132
Registriert: 12. Jul 2015, 13:21
Wohnort: Austria

Re: Fehler nach neuer PHP-Version

Beitragvon XimeX » 5. Jan 2019, 19:05

Die alten Admidio versionen funktionieren nicht mit PHP 7.x
Du musst entweder Admidio updaten oder auf eine alte PHP Version zurückkehren
chrissy-dizzy
Beiträge: 102
Registriert: 24. Jun 2010, 17:35

Re: Fehler nach neuer PHP-Version

Beitragvon chrissy-dizzy » 5. Jan 2019, 19:34

Nach Rückkehr zur alten Version komme ich auf die Admidio-Seite, erhalte aber folgende Fehlermeldung:

Die Datenbankversion 2.2.9 stimmt nicht mit der Version der Admidio-Scripte 2.1.11 überein.

Kann ich das händisch korrigieren?
Benutzeravatar
fasse
Administrator
Beiträge: 4772
Registriert: 12. Nov 2005, 16:06

Fehler nach neuer PHP-Version

Beitragvon fasse » 7. Jan 2019, 08:59

Hast du mal die Updateseite aufgerufen?

Ansonsten in der constants.php die Version auf 2.2.9 anpassen.

Generell solltest du aber jetzt mal ein Update auf die 3.x erwägen.
chrissy-dizzy
Beiträge: 102
Registriert: 24. Jun 2010, 17:35

Re: Fehler nach neuer PHP-Version

Beitragvon chrissy-dizzy » 7. Jan 2019, 13:38

Hi Fasse,

um das Update durchzuführen, muss ich zunächst in die bestehende Version reinkommen. Das klappt jedoch nicht, Nach der Änderung ergibt sich jetzt folgende Fehlermeldung:

Die Datenbankversion 2.2.9 stimmt nicht mit der Version der Admidio-Scripte 2.2.9 überein.

Danke für Deinen Support!
XimeX
Developer
Beiträge: 1132
Registriert: 12. Jul 2015, 13:21
Wohnort: Austria

Re: Fehler nach neuer PHP-Version

Beitragvon XimeX » 7. Jan 2019, 20:23

Für was musst du in der bestehenden Version hineinkommen?
Backup? Müsste ja auch direkt über die DB gehen
chrissy-dizzy
Beiträge: 102
Registriert: 24. Jun 2010, 17:35

Re: Fehler nach neuer PHP-Version

Beitragvon chrissy-dizzy » 7. Jan 2019, 22:02

Ok, danke
Zuletzt geändert von chrissy-dizzy am 10. Jan 2019, 00:57, insgesamt 1-mal geändert.
XimeX
Developer
Beiträge: 1132
Registriert: 12. Jul 2015, 13:21
Wohnort: Austria

Re: Fehler nach neuer PHP-Version

Beitragvon XimeX » 7. Jan 2019, 23:58

Ich glaube da verstehst du was falsch.
Du musst einfach die Dateien für Admidio v3.x hinkopieren und dann das update durchführen.
chrissy-dizzy
Beiträge: 102
Registriert: 24. Jun 2010, 17:35

Re: Fehler nach neuer PHP-Version

Beitragvon chrissy-dizzy » 10. Jan 2019, 19:19

Ok, danke - manchmal denkt man um zu viele Ecken. Das Update hat soweit geklappt, nur ein Fehler ist noch da: Unter "Angemeldet als" werden nicht die Daten, sondern
#PLG_LOGIN_ACTIVE_SINCE#
#PLG_LOGIN_LAST_LOGIN#
#PLG_LOGIN_NUMBER_OF_LOGINS#

angezeigt.
XimeX
Developer
Beiträge: 1132
Registriert: 12. Jul 2015, 13:21
Wohnort: Austria

Re: Fehler nach neuer PHP-Version

Beitragvon XimeX » 11. Jan 2019, 10:13

Versuch mal die cookies zu löschen
chrissy-dizzy
Beiträge: 102
Registriert: 24. Jun 2010, 17:35

Re: Fehler nach neuer PHP-Version

Beitragvon chrissy-dizzy » 23. Jan 2019, 14:29

Danke - hat funktioniert!

Zurück zu „Fehlermeldungen“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 8 Gäste