E-Mail-Versand scheint unzuverlässig

Hast du einen Fehler in der aktuellen Version gefunden ? Diesen kannst du uns hier mitteilen und uns bei der Fehlersuche helfen.
Antworten
Solluh
Beiträge: 60
Registriert: 25. Feb 2007, 20:30
Wohnort: bei Berlin
Kontaktdaten:

E-Mail-Versand scheint unzuverlässig

Beitrag von Solluh »

Liebe Community,
mit dem folgenden Problem schlage ich mich jetzt schon seit langer Zeit herum: mein Vorstandsvorsitzender (als Admin in Admidio angemeldet) berichtet, dass von ca. 130 E-Mails, die an die Rolle "Mitglieder" gesendet werden, viele nicht ankommen, da er wenig Resonanz auf seine Nachrichten erhält. Von einigen Mitgliedern hat der die Rückmeldung, dass keine E-Mail angekommen sei.
Es hapert immer noch, obwohl ich unlängst von PHP-Mail auf SMTP umgestiegen bin (Provider: 1und1). Die Test-E-Mails kommen immer an.
Auch werden die E-Mails an die Rollenmitglieder nicht in der Nachrichten-Historie angezeigt, was mir auch seltsam erscheint.
Dieses Phänomen tritt auch nach jedem Update weiter auf.
Letzte Rückmeldung von meinem Vorstand mit Version 4.1.8, jetzt aber Update auf 4.1.10 gemacht.

Kann ich als Admin die versendeten E-Mail von anderen Admins oder von anderen Rollenmitgliedern sehen?
Kann ich irgendwie debuggen, wenn der Vorstand eine E-Mail versendet?
Hat irgendjemand eine Ahnung, warum der Versand bei einigen Mitgliedern funktioniert und bei anderen nicht?

Ich bin ein bisschen verzweifelt, weil ich nicht weiter weiß und wäre dankbar für jeden Hinweis!

Gruß
Solluh
biggi422
Beiträge: 158
Registriert: 16. Nov 2020, 09:56

Re: E-Mail-Versand scheint unzuverlässig

Beitrag von biggi422 »

Ich habe das Problem auch mal gehabt, bei mir lag es an fehlenden Emailadressen bei den selbst angelegten Mitgliedern. Wenn keine Email Adresse vorhanden war haben nur die Mitglieder eine erhalten die vor dem fehlenden Feld befindlich waren. Wenn alle Adressen vorhanden waren lief es reibungslos. Daher bin ich irgendwann hingegangen und habe eine Fake Email angelegt und die die keine Email Adresse hatten, diese Mail zugewiesen. Hat geklappt, ich nutze eigenen SMTP Mailversand.
Benutzeravatar
fasse
Administrator
Beiträge: 5496
Registriert: 12. Nov 2005, 16:06

Re: E-Mail-Versand scheint unzuverlässig

Beitrag von fasse »

Hmm, wenn das so ist wie biggi schreibt, Welle dass ein Fehler von Admidio.

Es sollen eigentlich nur die Mitglieder ohne Emailadresse herausgefiltert werden.
Solluh
Beiträge: 60
Registriert: 25. Feb 2007, 20:30
Wohnort: bei Berlin
Kontaktdaten:

Re: E-Mail-Versand scheint unzuverlässig

Beitrag von Solluh »

biggi422 hat geschrieben: 25. Mär 2022, 15:49 Daher bin ich irgendwann hingegangen und habe eine Fake Email angelegt und die die keine Email Adresse hatten, diese Mail zugewiesen. Hat geklappt, ich nutze eigenen SMTP Mailversand.
Vielen Dank, das werde ich mal versuchen!
Solluh
Beiträge: 60
Registriert: 25. Feb 2007, 20:30
Wohnort: bei Berlin
Kontaktdaten:

Re: E-Mail-Versand scheint unzuverlässig

Beitrag von Solluh »

Nun habe ich allen Mitgliedern ohne E-Mailadresse (die selbe) Fake-E-Mail-Adresse gegeben: keine Änderung. Mein Vorstand sagt, dass es offenbar wieder nicht angekommen sei - auf dem Fake-Account habe ich (nur) eine E-Mail gefunden (was aber bestimmt von Admidio absichtlich so gemacht wird).
Da es sich um Einladungen zur HV handelt, hätte er mehr Reaktionen von den Mitgliedern erhalten, da diese alle alt und zuverlässig sind.

Auch in der Historie ist die neue E-Mail nicht enthalten.

Dank für weitere Vorschläge.

Kann ich in der Datenbank irgendetwas nachvollziehen?

Gruß
Solluh
biggi422
Beiträge: 158
Registriert: 16. Nov 2020, 09:56

Re: E-Mail-Versand scheint unzuverlässig

Beitrag von biggi422 »

Hallo Solluh,

da es scheinbar nicht daran liegt das leere Email Felder vorhanden sind, bleibt nur wenig um das zu prüfen. Wenn du Zugriff auf die Server-Mail-Logs hättest würde man auch sehen ob es abgesendet wird.

Ich will dich nicht auf dumme Gedanken bringen, aber... ;)

Ich war auch immer unsicher ob es wirklich funktioniert und mit meinen technischen Möglichkeiten konnte ich auch nichts weiteres herausbekommen. Jedoch habe ich festgestellt das wenn die Email Adresse nicht vorhanden war, es immer eine Rückmeldung vom empfangenden Server gibt wenn eine Mail nicht erreichbar ist. Ich habe dann von meinen 400 Mitgliedern ein Export (alle Felder!) gemacht, in Excel, einfach alle 400 Mailadressen geändert, habe vor jeder Mail eine Zeichenfolge gesetzt in Form von nwjdue-emailadresse.original.de und diese Emailadresse für den Test wieder Importiert und die Daten ersetzt. Dann habe ich eine Testmail geschrieben und mit den falschen Email-Adressen abgesendet und tatsächlich für alle Emailadressen ein Rückmeldung vom empfangenden Server erhalten. Stichwort MAIL DELIVERY FAILURE..... So konnte ich zweifelsfrei feststellen das die Mails versendet wurden. Danach die originale Export Datei wieder in Admidio importiert und die Daten wieder hergestellt.

Ich weiss, ziemlich einfacher Test. Doch nun wusste ich das die Mails ankommen. Wer es angeblich nicht erhalten hat, wurde auf den Spam Ordner hingewiesen und die Server Test Mail angehängt. Mehr konnte ich dann nicht machen.

Aber Ende vom Lied war das ich sicher war das Admidio erstklassige Arbeit verrichtet.
greno
Beiträge: 104
Registriert: 25. Nov 2017, 19:58

Re: E-Mail-Versand scheint unzuverlässig

Beitrag von greno »

Hallo Solluh,
dem letzten Satz aus biggi422 Statement vom 22.02.2022:
Aber Ende vom Lied war das ich sicher war das Admidio erstklassige Arbeit verrichtet.
kann ich überzeugt zustimmen !
Hast du mal in die Einstellungen/Allgemein/E-Mailversand und Einstellungen/Module/Nachrichten angepasst ?
Ich kann mich noch daran erinnern, dass admidio in meine Kopie der E-Mail auch alle Empfänger dieser E-Mail aufgelistet hat !
Ist dann aber bei einer neueren Version wieder 'verschwunden'.
Halle Fasse, könnte man da nicht in der config.php einen Parameter einbauen der gegebenenfalls alle Empfänger dieser E-Mail auflistet ? Ähnlich dem debug Parameter !
grusz greno
biggi422
Beiträge: 158
Registriert: 16. Nov 2020, 09:56

Re: E-Mail-Versand scheint unzuverlässig

Beitrag von biggi422 »

Wenn es darum geht das man dort etwas einstellen oder ausgeben kann, da wäre ich auch dabei.

Wenn nach dem Absenden aus dem Mail Programm quasi bestätigt wird das diese Email versendet wurde, das wäre schon gut. Ob das machbar ist werden die Programmier Profis von Admidio schon wissen. Und wenn wir dabei sind würde ich gerne wissen ob die Mails Blockweise versendet werden oder ob diese komplett durchgearbeitet werden. Günstig wäre das man den Mailversand so steuert das immer nur 20-40 versendet werden. Und dann so lange bis alle aus der Rolle angeschrieben sind. Weiss wirklich nicht wie es momentan gemacht wird.
greno
Beiträge: 104
Registriert: 25. Nov 2017, 19:58

Re: E-Mail-Versand scheint unzuverlässig

Beitrag von greno »

Hallo biggi422,
bei Einstellungen/Allgemein/E-Mailversand findet man Anzahl der BCC mit dem Default-Wert 50; daraus ergeben sich für mich die Blöcke der zu versendenden E-Mails. Habe bei mir den Wert auf > 50 gestellt; funktioniert prima!
grusz greno
Solluh
Beiträge: 60
Registriert: 25. Feb 2007, 20:30
Wohnort: bei Berlin
Kontaktdaten:

Re: E-Mail-Versand scheint unzuverlässig

Beitrag von Solluh »

Vielen lieben Dank für eure Unterstützung, leider hatte ich schon alle Einstellungen geprüft, geändert, daran gefeilt und nochmal überprüft, es wird nicht besser.
Besonders erstaunt mich, dass im Nachrichten-Protokoll die E-Mails auch nicht auftauchen, ich habe in der Datenbank nachgesehen, die Nachrichtennummern sind nicht fortlaufend.
Gerade habe ich per Fernwartung bei meinem Vorstand den Nachrichtenversand "überwacht" - allerdings nur an die Rolle Admin mit 2 Usern. Hat funktioniert. In der Historie ist die Nachricht enthalten.
Meine Frage, on der Admidio-Hinweis "Nachricht versandt" auch bei den "teilweise unzugestellen" E-Mails kam wurde bejaht. Trotzdem kein Eintrag in der Datenbank, trotzdem viele User ohne E-Mail.
Ich habe mal einen Screenshot gamacht, auf dem man die Lücke zwischen den Nachrichten 226 und 233 erkennen kann:
Bildschirmfoto 2022-03-29 um 17.05.14.jpg
Bildschirmfoto 2022-03-29 um 17.05.14.jpg (221.15 KiB) 4022 mal betrachtet
Die Datenbank ist noch MySQL 5.5, das ist doch in Ordnung, oder? Die Systeminfos von Admidio sagen jedenfalls "grün".
Nochmals Dank!
Solluh
biggi422
Beiträge: 158
Registriert: 16. Nov 2020, 09:56

Re: E-Mail-Versand scheint unzuverlässig

Beitrag von biggi422 »

Solluh hat geschrieben: 29. Mär 2022, 17:12 Ich habe mal einen Screenshot gamacht, auf dem man die Lücke zwischen den Nachrichten 226 und 233 erkennen kann:
Bildschirmfoto 2022-03-29 um 17.05.14.jpg

Wenn das aus der Datenbak unter messages ist, können die Lücken ja auch daher rühren da dort ja nicht nur die Emails gelistet sind. Auch PM sind dort drin und wenn die vom Nutzer gelöscht werden dann fehlen die in der Datenbank und daher könnten auch die Lücken kommen.

Es wird nur eine Email angezeigt das sagt nix aus. Dort siehst du nur das eine verfasst wurde, sonst nix....
MoinMoin
Beiträge: 74
Registriert: 8. Apr 2015, 08:43

Re: E-Mail-Versand scheint unzuverlässig

Beitrag von MoinMoin »

Ich habe ein ähnliches Problem:

Heute habe ich eine Mail erfolgreich an alle Mitglieder versendet.

Ein paar Minuten später wieder eine Mail an den selben Adressatenkreis, ohne dass eine Änderung in der Datenbank stattgefunden hätte.
Diese Mail ist dann nicht rausgegangen, an vermutlich keinen Adressaten.
Ich habe auch keine Kontrollkopie erhalten, obwohl das Kästchen angeklickt war.

Im Protokoll ist die besagte Mail auch nicht gelistet.

Die Fehlermeldung sagte, dass eine der angeschriebenen Mailboxen nicht erreicht werden kann, weil diese angeblich voll ist.

Ein zweiter Versuch mit dieser Mail, diesmal mit Chrome statt Firefox, endete ähnlich, nur dass diesmal ein anderer Adressat mit einer angeblich vollen Mailbox gemeldet wurde.
Solche Fehlermeldungen erscheinen normalerweise im der als Absender eingetragenen Mailbox aber nicht beim Versand mit Admidio...

Update:
Eine Stunde später war dann ein weiterer Versuch mit der gleichen Mail an den selben Adressatenkreis erfolgreich.
Einziger Unterschied: Ich hatte in bei den ersten Versuchen ein Ausrufungszeichen "!" im Betreff, den ich im letzten Versuch weggelassen habe... Kann das der Grund für den gescheiterten Mailversand gewesen sein ?
Benutzeravatar
fasse
Administrator
Beiträge: 5496
Registriert: 12. Nov 2005, 16:06

Re: E-Mail-Versand scheint unzuverlässig

Beitrag von fasse »

Hallo MoinMoin,

also ein volles Postfach kann eigentlich kein Grund für einen Mailversand sein. Das PHP-Script versendet die E-Mails ohne auf eine Rückmeldung des jeweiligen E-Mail-Empfänger-Servers zu warten.

Das mit dem Ausrufezeichen ist interessant. Vielleicht kann das auch mal jemand anders testen.

Tritt das Problem mit dem Ausrufezeichen bei dir auch auf, wenn du nur 1 Mitglied gezielt anschreibst?
Vielleicht war es aber auch nur Zufall mit dem Ausrufezeichen.

Viele Grüße
Fasse
greno
Beiträge: 104
Registriert: 25. Nov 2017, 19:58

Re: E-Mail-Versand scheint unzuverlässig

Beitrag von greno »

Hallo,
habe soeben eine Testmail mit ! im Betreff an EINEN Empfänger versandt !
Ist sowohl beim Empfänger als auch als Kopie bei mir angekommen !
grusz greno
Antworten