Probleme bei update von 2.4.7 auf aktuelle 3.3.8

Hast du Probleme Admidio einzurichten? Hier kannst du Fragen rund um die Einrichtung stellen.
DieterB
Beiträge: 81
Registriert: 1. Mai 2009, 23:31

Probleme bei update von 2.4.7 auf aktuelle 3.3.8

Beitragvon DieterB » 29. Dez 2018, 19:52

Hallo,

nach einigen Jahren ohne Problemen, muss ich mich wieder einmal hier melden.

Wegen des erforderlichen updates auf php 7.x muss ich mein Admidio 2.4.7 wohl auf 3.3.8 updaten (oder?).

Ich bin folgendermaßen vorgegangen:
1) Sicherung der DB und aller scripten.
2) Löschen (Unbenenen in *.old) der index.php und der Ordner adm_program und adm_themes.
3) Aktualisieren der nun noch notwendigen plugins im adm_Plugins Ordner
4) Hochladen der neuen entpackten adm_program und adm_themes Ordner
5) Hochladen der index.php ins Hauptverzeichnis
6) Aufrufen der index.php im Hauptverzeichnis.
Dabei wurde die Umwandlung der DB mit einem Fehler (zu lange script Laufzeit?) abgebrochen.
Nach erneutem Aufruf kam aber die Meldung, dass die DB ok ist, allerdings danach nur eine leere Seite.

7) Erneutes Aufspielen des original adm_program Ordners und der index.php und Wiederherstellen der alten config.php Konfiguration
8) Einspielen der alten 2.4.7 Datenbank.
9) Nach Aufruf der index.php lief die erneute Konvertierung zügig mit Erfolgsmeldung durch, allerdings bekam ich danach wieder nur eine leere Seite nach Aufruf der index.php in adm_program. Die config.php war im richtigen Ordner (adm_my_files).

Nach Rücksetzen der DB und der alten scripten funktioniert wieder alles.
Was kann ich aber nun noch machen, um zum Update zu kommen?

Vielen Dank für Eure Hilfe.
XimeX
Developer
Beiträge: 1054
Registriert: 12. Jul 2015, 13:21
Wohnort: Austria

Re: Probleme bei update von 2.4.7 auf aktuelle 3.3.8

Beitragvon XimeX » 30. Dez 2018, 12:21

schalte mal den debug modus ein bevor du das update machst.
in der config.php "$gDebug = true;" setzen. und dann schau dir auch die logs in adm_my_files an. sollte auch hinweise auf probleme geben.

Und ja für PHP 7.x brauchst du admidio v3.x
Benutzeravatar
fasse
Administrator
Beiträge: 4717
Registriert: 12. Nov 2005, 16:06

Re: Probleme bei update von 2.4.7 auf aktuelle 3.3.8

Beitragvon fasse » 2. Jan 2019, 16:35

Hallo Dieter,

wir haben aktuell noch dieses Problem https://github.com/Admidio/admidio/issues/852 was wohl bei dir auch einen Fehler wirft.

In der kommenden 3.3.9, welche spätestens am Wochenende raus kommt ist es behoben. Alternativ kannst du auch selber die Änderung aus dem Issue vornehmen.

Gruß
Fasse
DieterB
Beiträge: 81
Registriert: 1. Mai 2009, 23:31

Re: Probleme bei update von 2.4.7 auf aktuelle 3.3.8

Beitragvon DieterB » 2. Jan 2019, 17:37

Danke für die Infos,

nach mehreren Versuchen (ich verstehe nicht ganz was ich anders gemacht habe, Fehler 852 habe ich nicht selbst behoben) hat es nun prinzipiell geklappt.

Es scheinen auch die meisten Dinge zu funktionieren. Ein Problem habe ich mit der Geburtstagsliste (-> neues Thema) ...

und mit den eigenen Listen. Da bekomme ich beim Aufruf noch folgenden Fehler:

Code: Alles auswählen

Fatal error: Uncaught exception 'InvalidArgumentException' with message 'Settings value of name "lists_default_configuration" is not of type int!' in /.../web/admidio3/adm_program/system/classes/SettingsManager.php:176 Stack trace: #0 /.../web/admidio3/adm_program/system/classes/TableLists.php(46): SettingsManager->getInt('lists_default_c...') #1 /.../web/admidio3/adm_program/modules/lists/mylist.php(597): TableLists->delete() #2 {main} thrown in /.../web/admidio3/adm_program/system/classes/SettingsManager.php on line 176


PHP 5.5
MySQL 5.1
XimeX
Developer
Beiträge: 1054
Registriert: 12. Jul 2015, 13:21
Wohnort: Austria

Re: Probleme bei update von 2.4.7 auf aktuelle 3.3.8

Beitragvon XimeX » 2. Jan 2019, 23:17

Schau mal bitte in der preferences tabelle nach ob du bei prf_name einen eintrag findest:
"lists_default_configuration" ODER "lists_default_configuation" (mit typo -> fehlendes r) und welchen prf_value der eintrag hat.
DieterB
Beiträge: 81
Registriert: 1. Mai 2009, 23:31

Re: Probleme bei update von 2.4.7 auf aktuelle 3.3.8

Beitragvon DieterB » 3. Jan 2019, 19:32

Es existiert nur prf_name lists_default_configuration mit leerem prf_value.
XimeX
Developer
Beiträge: 1054
Registriert: 12. Jul 2015, 13:21
Wohnort: Austria

Re: Probleme bei update von 2.4.7 auf aktuelle 3.3.8

Beitragvon XimeX » 4. Jan 2019, 21:04

@Fasse: sollte lists_default_configuration nicht hier gesetzt werden?
https://github.com/Admidio/admidio/blob ... #L299-L303
DieterB
Beiträge: 81
Registriert: 1. Mai 2009, 23:31

Re: Probleme bei update von 2.4.7 auf aktuelle 3.3.8

Beitragvon DieterB » 8. Jan 2019, 12:00

Ich bitte hier noch einmal um Hilfe, was kann ich tun?
DieterB
Beiträge: 81
Registriert: 1. Mai 2009, 23:31

Re: Probleme bei update von 2.4.7 auf aktuelle 3.3.8

Beitragvon DieterB » 11. Jan 2019, 15:37

Hallo,

ich habe es jetzt mit der Version 3.3.9 probiert.

Das Problem mit den eigenen Listen scheint wohl nur daran zu liegen, dass im Menü nach wie vor ein Menüpunkt "Eigene Liste" mit dem URL /adm_program/modules/lists/mylist.php besteht. Dieser funktioniert bei mir nach wie vor nicht:

Code: Alles auswählen

Diese Seite funktioniert nicht www.union-staw.at kann diese Anfrage momentan nicht verarbeiten.
HTTP ERROR 500


Allerdings komme ich über die "Listen" nun auch auch zu meinen eigenen Listen. Ist das ein genereller Fehler bei Euch oder stimmt da bei mir nach wie vor etwas nicht? Den link "Eigene Liste" kann ich allerdings auch nicht löschen.

Zusätzlich habe ich jetzt noch das Problem, dass ich die Installation in einem Ordner admidio3 durchgeführt habe, dieser steht auch in der config.php als $g_root_path.
Wenn ich den Ordner umbenenne (in admidio) und den Pfad in der config.php ändere arbeitet das Programm, allerdings werden keine Einträge von Mitgliedern gefunden. Was muss man noch ändern, wenn man den Pfad der Installation ändert?

Zurück zu „Fragen und Probleme beim Einrichten von Admidio“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste