Speicherort des Admidio-Ordner geändert, dadurch Probleme mit Sprachdatei

Hast du Probleme Admidio einzurichten? Hier kannst du Fragen rund um die Einrichtung stellen.
exwima
Beiträge: 5
Registriert: 28. Mär 2015, 21:47

Speicherort des Admidio-Ordner geändert, dadurch Probleme mit Sprachdatei

Beitragvon exwima » 12. Jul 2019, 00:31

Hallo zusammen,

wir haben bei unserer Domain zwei Subdomains, chorintern.domain... und admidio.domain... Allerdings war leider der Admidio-Ordner im Dateisystem unterhalb von "chorintern" angelegt, was manchmal zu Verwirrung geführt hat.
Daher habe ich heute den Ordner der Admidio-Installion im Dateisystem eine Stufe hochgezogen (die Datenbank bleibt gleich, die config ändert sich auch nicht):

1. Bestehenden Ordner an den neuen Speicherort kopiert.
2. Rechte des adm_my_files-Ordners passend gesetzt.
3. Speicherort für die Subdomain auf den neuen Ordner geändert
--> Admidio lässt sich problemlos aufrufen, auch alle Funktionen tun, soweit ich das beurteilen kann

4. Alten Admidio-Ordner in "admidio-alt-2019-07" umbenannt
--> Admidio lässt sich weiterhin problemlos öffnen und scheint auch zu funktionieren, mehrere Funktionen habe ich problemlos aufgerufen
--> An manchen Stellen gibt es aber plötzlich Anzeigefehler, der darzustellende Text wird augenscheinlich nicht gefunden, stattdessen wird z.B. in der Änderungshistorie eines Nutzers die Tabellenüberschriften als #SYS_FIELD#, #SYS_NEW-VALUE#, usw angezeigt.

5. Alten Admidio-Order wieder in "admidio" umbenannt (Subdomain zeigt aber weiter auf den neuen Ordner)
--> Die fehlenden Texte werden geladen und normal angezeigt

6. Alten Admidio-Ordner wieder in "admidio-alt" umbenannt
--> Die in 5. "wiedergefundenen" Texte werden weiterhin richtig angezeigt.

Für mich sieht das so aus, als würden die anzuzeigenden Texte noch im alten Ordner am alten Speicherort gesucht statt am neuen Speicherort, wo die Sprachdateien natürlich auch vorhanden wären (wurden ja kopiert). Und dass die Texte teilweise doch angezeigt werden, nachdem sie einmal gefunden wurden, liegt womöglich an irgendeiner Form von (serverseitigem) Caching.

In der Logdatei finden sich dementsprechend auch etliche Einträge, dass ein Text nicht gefunden wurde:

Language.php liegt im richtigen Ordner: public/admidio/ usw.
[2019-07-11 23:24:45.836831] Admidio.ERROR: L10N: Could not found text-id! {"textId":"ROL_SHOW_MEMBERS"} {"file":"/UnserPfad/public/admidio/adm_program/system/classes/Language.php","line":119,"class":"Language","function":"get"}

Language.php sucht aber noch im alten Ordner: public/chorintern/admidio/ usw.
[2019-07-11 23:24:45.836882] Admidio.ERROR: L10N: Language file does not exist! {"languageFilePath":"/UnserPfad/public/chorintern/admidio/adm_program/languages/de.xml"} {"file":"/UnserPfad/public/admidio/adm_program/system/classes/Language.php","line":440,"class":"Language","function":"searchLanguageText"}


Wie kann ich Admidio beibringen, dass es seine Sprachdateien bitte im neuen Ordner suchen soll, relativ zur aufrufenden Datei?
Oder soll ich den Plan, die Ordner klarer zu trennen, lieber wieder aufgeben und zurück auf den alten Speicherort wechseln?

Für Tipps und Hilfe wäre ich dankbar.
Viele Grüße
Juliane
Benutzeravatar
fasse
Administrator
Beiträge: 4752
Registriert: 12. Nov 2005, 16:06

Re: Speicherort des Admidio-Ordner geändert, dadurch Probleme mit Sprachdatei

Beitragvon fasse » 13. Jul 2019, 08:54

Hallo Juliane,

für mich klingt das nach einem Cache-Problem. Mal nach dem Umzug mit einem anderen Browser oder Geröt ausprobiert die Seite zu öffnen. Da sollte dann alles richtig dargestellt werden.

Gruß
Fasse
XimeX
Developer
Beiträge: 1130
Registriert: 12. Jul 2015, 13:21
Wohnort: Austria

Re: Speicherort des Admidio-Ordner geändert, dadurch Probleme mit Sprachdatei

Beitragvon XimeX » 14. Jul 2019, 10:18

Lösch mal bitte deine Cookies im Browser. Löst dass das Problem?
exwima
Beiträge: 5
Registriert: 28. Mär 2015, 21:47

Re: Speicherort des Admidio-Ordner geändert, dadurch Probleme mit Sprachdatei

Beitragvon exwima » 14. Jul 2019, 17:21

Hallo Fasse, hallo XimeX,

Danke für eure Antworten! Aktuell tritt das Phänomen nicht mehr auf, weder in meinem "normalen" Standard-Browser noch in einem anderen Browesr und auf einem anderen Gerät. Also wohl wirklich ein Cache-Problem. Uff.

Der Ordner am alten Speicherort ist wieder in "admidio_alt" umbenannt, aber noch da, falls das Problem mit der nicht gefundenen Sprachdatei doch nochmal auftaucht. Die Cookies habe ich bei mir sicherheitshalber nochmal gelöscht, auch danach stimmten die Benennungen in Admidio weiterhin. Ich werde es wohl noch etwas beobachten, bevor ich den alten Ordner endgültig lösche. ;-)

Viele Grüße
Juliane

Zurück zu „Fragen und Probleme beim Einrichten von Admidio“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 5 Gäste