Neu-Installation - Mitgliedsbeitrag

Hast du Probleme oder Fragen bei der Einrichtung bestimmter Plugins ? Diese kannst du hier loswerden.
Antworten
EddyB
Beiträge: 13
Registriert: 27. Jul 2022, 11:00

Neu-Installation - Mitgliedsbeitrag

Beitrag von EddyB »

Hallo zusammen,
ich habe gerade Admidio (Admidio-Version: 4.1.13) zum erstmal installiert und versuche nun verzweifelt ein Plugin zu installieren.

Bisher:
Habe das Plugin (https://www.admidio.org/dokuwiki/doku.p ... edsbeitrag) runtergeladen, wie beschrieben in den Ordner /adm_plugins/ den Ordner /mitgliedsbeitrag/ angelegt und den Inhalt vom Download eingefügt.
https://domin.de/adm_plugins/mitgliedsb ... eitrag.php ausgeführt und folgende Meldung erhalten
Fehler

Die Authorisierungsprüfung des Plugins ist fehlgeschlagen. Es ist mehr als ein Menüpunkt mit derselben URL definiert.

=> /adm_plugins/mitgliedsbeitrag/mitgliedsbeitrag.php
irgendwie stehe ich nun auf dem Schlauch
rmb
Plugin-Developer
Beiträge: 572
Registriert: 10. Mai 2011, 19:56
Wohnort: 86856

Re: Neu-Installation - Mitgliedsbeitrag

Beitrag von rmb »

Hallo EddyB,

die Ordnerstruktur ist schon mal richtig angelegt (ansonsten würdest du die Meldung nicht erhalten).

Im Menü von Admidio hast du einen Menüpunkt erzeugt. Hast du hier evtl. (zum Ausprobieren) mehrere Menüeinträge angelegt? => Diese Meldung kommt, wenn mehrere Menüpunkte auf dieselbe URL deuten.

Du kannst auch mal den Debug-Modus einschalten. Dazu in der config.php (in adm_my_files) die Zeile $gDebug=1; einfügen. Jetzt das Plugin nochmal starten. In der logs-Datei (adm_my_files/logs) sollten jetzt mindestens zwei Einträge stehen wie: "MembershipFee: Error with...... Die Angaben zu "Found rows" und "ScriptName" wären hilfreich.

Gruß

rmb
EddyB
Beiträge: 13
Registriert: 27. Jul 2022, 11:00

Re: Neu-Installation - Mitgliedsbeitrag

Beitrag von EddyB »

rmb hat geschrieben: 27. Jul 2022, 17:37 Hallo EddyB,

die Ordnerstruktur ist schon mal richtig angelegt (ansonsten würdest du die Meldung nicht erhalten).

Im Menü von Admidio hast du einen Menüpunkt erzeugt. Hast du hier evtl. (zum Ausprobieren) mehrere Menüeinträge angelegt? => Diese Meldung kommt, wenn mehrere Menüpunkte auf dieselbe URL deuten.

Du kannst auch mal den Debug-Modus einschalten. Dazu in der config.php (in adm_my_files) die Zeile $gDebug=1; einfügen. Jetzt das Plugin nochmal starten. In der logs-Datei (adm_my_files/logs) sollten jetzt mindestens zwei Einträge stehen wie: "MembershipFee: Error with...... Die Angaben zu "Found rows" und "ScriptName" wären hilfreich.

Gruß

rmb
Hi, Danke - habe inzwischen die Lösung gefunden, bzw. bin wie folgt vorgegangen;
- zuerst muss man /adm_plugins/mitgliedsbeitrag/installation.php - ausführen
- /adm_plugins/mitgliedsbeitrag/mitgliedsbeitrag.php - muss als Menüpunkt manuell angelegt werden und dann umgeht man auch all die aufkommenden Fehler.
Antworten