Blog

Admidio 3.1 released!
Admidio 3.1 is ready for download.

Many thanks to those of you who help us to get a stable version 3.1 of Admidio.

Some of the major enhancements in this version:

PHP7 compatibility
This is one of the main reasons for this release. Since PHP7 was released at the end of November and Admidio 3.0 is not compatible we want to release a compatible version as soon as possible. So with Admidio 3.1 you can use PHP7 and we don't have change the minimum requirements. You can still use PHP 5.3.

Security improvements
With this release we have added some security related enhancements.
- Passwords are now encoded and stored in the database with the bcrypt algorithm
- check session ip address to prevent session hijacking
- don't show specific error message if password is wrong. always show error message username or password wrong
- refresh auto login id on every script call
- create a more unique and secure id
- delete all auto login from user if count of invalid auto login > 3
- Always give positive feedback when requesting a new password to prevent evil users for scaning valid email addresses

Further integration of 3.0 features
We have continue to integrate the new features that we introduce with 3.0.
- Upload files with the new file upload dialog in download module
- New authorization dialog in download module
- New dialog for MyLists
- Bootstrap print view in events module
- and much more ...

The minimum requirements are the same as of Admidio 3.0:
*PHP 5.3.7*
*MySQL 5.0.3*
*Flash not required anymore* ☺

A detailed list of all changes can be found here.

Before you think about an update have a look at all of the plugins you use. Are they ready for 3.1?
If you use Admidio 2.x please have a look at our update documentation from version 2 to version 3.

Now get your copy of Admidio 3.1 and enjoy the new features.

The Admidio-Team

------------------

Admidio 3.1 steht jetzt zum Download bereit.

Vielen Dank an alle die uns in der Beta-Phase geholfen haben und so dass wir nun eine stabile 3.1 veröffentlichen können.

Einige der größeren Änderungen in dieser Version:

PHP7 Kompatibilität
Dies ist wohl der Hauptgrund für die Veröffentlichung dieser Version. PHP7 wurde Ende November veröffentlicht und Admidio 3.0 ist leider nicht kompatibel mit dieser Version da wir dort noch eine veraltete Bibliothek für den Datenbankzugriff verwendet haben. Admidio 3.1 ist jetzt vollständig kompatibel mit PHP 7 und kann dennoch weiterhin mit PHP 5.3 genutzt werden.

Sicherheitsverbesserungen
Mit diesem Release haben wir auch einige Verbesserungen an der Sicherheit der Anwendung vorgenommen.
- Passwörter werden nun mit bcrypt Algorithmus in der Datenbank abgelegt
- Die IP-Adresse wird bei jedem Zugriff geprüft. Ändert sich diese bei einer bestehenden Session wird die Verbindung beendet.
- Es wird keine spezielle Fehlermeldung bei einem falschen Loginversuch mehr angezeigt. In allen Fällen erscheint nur noch die Fehlermeldung, dass Benutzername oder Passwort falsch waren.
- Die Id für den AutoLogin wird bei jedem Seitenzugriff neu generiert. Somit ist es schwieriger für 3. an die richtige ID zu kommen.
- Nach 3 falschen Versuchen beim AutoLogin, wird das AutoLogin ungültig
- Wird ein Passwort neu angefordert, so wird nun immer eine positive Rückmeldung gegeben, damit Fremde nicht nach gültigen E-Mail-Adressen suchen können.

Weitere Integration von neuen Funktionen der 3.0
Wir haben einige neue Funktionen, welche mit Version 3.0 eingeführt wurden, weiter in das Programm eingebaut:
- Dateiupload im Downloadmodul nutzt nun denselben Uploader, wie das Fotomodul
- Zuordnung von Rollenrechten im Downloadmodul nutzt jetzt das Select2 Steuerelement
- Neu gestalteter Dialog für eigene Listen mit der Möglichkeit mehrere Rollen auszuwählen
- Druckvorschau im Terminmodul ist jetzt auch auf Bootstrap 3 umgestellt.
- und vieles andere ...

Die Systemvoraussetzungen sind dieselben geblieben, wie bei Admidio 3.0:
*PHP 5.3.7*
*MySQL 5.0.3*
*Flash wird nicht mehr benötigt* ☺

Eine detailierte Auflistung aller Änderungen können hier gefunden werden.

Bevor du über ein Update nachdenkst, schau dir bitte die Liste der Plugins an. Sind deine benötigten Plugins bereits für die 3.1 verfügbar?
Falls du noch Admidio 2.x benutzt, dann schau dir bitte die Update-Dokumentation von Version 2 auf Version 3 an.

Nun wünschen wir dir viel Freude an der Version und den neuen Funktionen.

Das Admidio-Team