Die Suche ergab 63 Treffer

von RalphW
24. Jun 2020, 07:03
Forum: Sonstiges
Thema: Änderung der Checkbox wird nicht erkannt
Antworten: 2
Zugriffe: 759

Re: Änderung der Checkbox wird nicht erkannt

Hallo Fasse,

Nein, daran liegt es nicht. Ich kann bei den Checkboxen setzen was ich will. Wenn ich auf Speichern clicke passiert nichts. Es ist wie wenn ich nichts verändert hätte. Erst wenn ich auch die Dropbox ändere, werden die Checkboxen berücksichtigt.

viele Grüße
Ralph
von RalphW
22. Mär 2020, 21:19
Forum: Fehlermeldungen
Thema: Sortierung für Löschen im Datenbank-Backup
Antworten: 1
Zugriffe: 400

Sortierung für Löschen im Datenbank-Backup

Ich habe eine kleine Fehler gefunden. In der Tabelle der Datenbank-Backups (adm_program/modules/backup/backup.php) kann die Spalte zum Löschen sortiert werden. Das ist natürlich nicht sinnvoll und sollte nicht möglich sein.
von RalphW
22. Mär 2020, 16:23
Forum: Sonstiges
Thema: Änderung der Checkbox wird nicht erkannt
Antworten: 2
Zugriffe: 759

Änderung der Checkbox wird nicht erkannt

Für mein Plugin habe ich ein Einstellungsseite gebaut, in der ich in die Tabelle 2 Settings speichere (list_per_page und table_columns_hide). Dazu habe ich den folgenden Code erstellt: $form = new HtmlForm( 'pref_form', safeUrl(PLG_URL . '_function.php', array('form' => 'pref')), $page, array('class...
von RalphW
17. Dez 2019, 18:21
Forum: Sonstiges
Thema: Message wird nicht im Theme angezeigt
Antworten: 2
Zugriffe: 997

Re: Message wird nicht im Theme angezeigt

Ich habe vermutlich das Problem gefunden: In einer Datei, die ich mit require_once einbinde war ?> mit 2x Enter am Ende.
Sobald das weg ist funktioniert es.
von RalphW
11. Dez 2019, 12:25
Forum: Fehlermeldungen
Thema: Überschrift Module wird angezeigt obwohl keine da
Antworten: 1
Zugriffe: 4675

Überschrift Module wird angezeigt obwohl keine da

Ich habe für einem speziellen Anwendungsfall alle Module deaktiviert. Leider wird in der Hauptseite die Überschrift "head_modules" angezeigt, obwohl keine Module aufgelistet werden. Bei Administration und Plugins funktioniert das. Außerdem wäre es nett, wenn auch die Reihenfolge der Übersc...
von RalphW
11. Dez 2019, 12:13
Forum: Verbesserungsvorschläge und Anregungen
Thema: Spracheinstellung individuell für User
Antworten: 1
Zugriffe: 1070

Spracheinstellung individuell für User

Wenn ich es richtig sehe, kann die Sprache nur für alle User eingestellt werden.

Wie kann ich aber die Sprache für einen einzelnen User einstellen, bzw. kann dieser die Sprache selbst wählen bzw. ändern?
von RalphW
11. Dez 2019, 08:54
Forum: Fehlermeldungen
Thema: addCustomContent() ignoriert class
Antworten: 1
Zugriffe: 4556

addCustomContent() ignoriert class

In der Klasse HtmlForm habe ich einen Fehler gefunden: Die Option 'class' wird ignoriert und nicht verarbeitet: $this->openControlStructure( $optionsAll['referenceId'], $label, self::FIELD_DEFAULT, $optionsAll['helpTextIdLabel'], $optionsAll['icon'], 'form-custom-content' ); Mit einer kleinen Änderu...
von RalphW
9. Dez 2019, 03:50
Forum: Sonstiges
Thema: Message wird nicht im Theme angezeigt
Antworten: 2
Zugriffe: 997

Message wird nicht im Theme angezeigt

Ich habe ein Plugin erstellt und dabei folgendes Problem. Ich prüfe die Berechtigung: if (!hasRole('Administrator') { $gMessage->show($gL10n->get('SYS_NO_RIGHTS')); } Das funktioniert prinzipiell. Nur leider wird mir der Hinweis in einem weißen Fenster und nicht im Theme angezeigt. Jetzt habe ich in...
von RalphW
14. Jul 2019, 11:10
Forum: Sonstiges
Thema: Plugin Funktionen funktionieren im Header nicht
Antworten: 6
Zugriffe: 1771

Re: Plugin Funktionen funktionieren im Header nicht

Danke, jetzt funktioniert es.
von RalphW
14. Jul 2019, 10:54
Forum: Sonstiges
Thema: Wie kann man Languages in eigenem Plugin verwenden
Antworten: 7
Zugriffe: 1913

Re: Wie kann man Languages in eigenem Plugin verwenden

3.3.10

Ich habe mir gerade die aktuelle Datei heruntergeladen und nachgesehen. Da ist das nicht drinnen.
von RalphW
14. Jul 2019, 10:32
Forum: Sonstiges
Thema: Wie kann man Languages in eigenem Plugin verwenden
Antworten: 7
Zugriffe: 1913

Re: Wie kann man Languages in eigenem Plugin verwenden

Fehler gefunden. In der de.xml hat sich im Text ein & eingeschlichen. Das hat den Absturz verursacht. Nebenbei hat der Debug noch einen Fehler im sidebar_online.php zu Tage gefördert. $plg_show_headline wird nicht geprüft ob, ob sie exisitert. Ich habe also if(!isset($plg_show_headline) || !is_n...
von RalphW
14. Jul 2019, 10:17
Forum: Sonstiges
Thema: Plugin Funktionen funktionieren im Header nicht
Antworten: 6
Zugriffe: 1771

Re: Plugin Funktionen funktionieren im Header nicht

Ja so funktioniert es, wenn ich den ganzen Pfad angebe.

Muss ich vielleicht

Code: Alles auswählen

$data = file_get_contents($GLOBALS['plg_data_file']);

schreiben?
von RalphW
14. Jul 2019, 10:12
Forum: Sonstiges
Thema: Eigene Dateien lesen und schreiben
Antworten: 5
Zugriffe: 1416

Re: Eigene Dateien lesen und schreiben

Ich wusste ja nicht, dass es eine Standard PHP Funktion mit dem fast gleichen Namen gibt. Scheinbar ist da die Groß-/Kleinschreibung nicht relevant.

Danke jetzt funktioniert es.

Mit dieser Schreibweise funktioniert jetzt auch FileSystemUtils::writeFile(). writeFile() alleine funktioniert nicht.
von RalphW
14. Jul 2019, 09:45
Forum: Sonstiges
Thema: Eigene Dateien lesen und schreiben
Antworten: 5
Zugriffe: 1416

Re: Eigene Dateien lesen und schreiben

Also wenn ich $data = readFile('$fileName'); schreibe wird ganz oben der Inhalt der Datei ausgegeben und die Variable $data enthält die Länge der Datei. Es sieht so aus als würde in FileSystemUtils.php die Funktion readFile nicht durchlaufen. Kann es sein, dass die PHP Funktion readfile() verwendet ...
von RalphW
14. Jul 2019, 09:25
Forum: Sonstiges
Thema: Wie kann man Languages in eigenem Plugin verwenden
Antworten: 7
Zugriffe: 1913

Re: Wie kann man Languages in eigenem Plugin verwenden

Den Cache habe ich auch mehrfach gelöscht. Daran liegt es nicht. Doppelt sind sie auch nicht vergeben. Wenn ich die Datei de.xml auf xde.xml umbenenne, dann schreibt er mir den Key hin: #PLG_TITLE# Wenn ich alle $gL10n Einträge raus nehme geht es auch nicht. Also sobald die Datei de.xml existiert cr...

Zur erweiterten Suche