Fehler in passwordhashing.php

Themen aus älteren Betatests.
kanu
Beiträge: 58
Registriert: 22. Okt 2009, 17:27
Wohnort: Kiel
Kontaktdaten:

Re: Fehler in passwordhashing.php

Beitragvon kanu » 30. Nov 2016, 11:40

XimeX hat geschrieben:Wenn wir das einbauen sollten wir eine Überprüfung auf den Wert 31 machen. Dieser ist der maximale Wert (außer man verwendet das SHA512 Verfahren. Dann liegts bei 999999999. Deswegen auch _nicht_ >=31 abfragen)
Werte über 10 sind nichts besonderes. Eigentlich sollten die Server stark genug sein um zumindest 12 zu schaffen. Alles über 20 wäre sehr hoch für die _heutige_ Zeit. Aber noch im grünen Bereich.
Auf meinem Notebook braucht er bei cost=20 ca 60sec für einen Hash. Man sagt die ideale Hashzeit ist so zwischen 0,2 und 0,4sec.
Aber 60sec würden nicht gleich Schuld sein dass das Script abbricht. (Achtung: Stufen steigen Exponentiell!)

Falls wir noch eine neue v3.1 rausbringen sollten wir das dort auch einbauen. Falls sich die Fälle häufen sollten wir auf alle Fälle eine neue Version rausbringen.


Bei mir läuft Admidio auf einem Bananapi-Board (mit SSD). Die Performance ist in Ordnung, aber der hohe Wert fürs hashing ist so nachvollziehbar. ;)
verwendet Admidio auf rgk.org 8)
XimeX
Developer
Beiträge: 1147
Registriert: 12. Jul 2015, 13:21
Wohnort: Austria

Re: Fehler in passwordhashing.php

Beitragvon XimeX » 30. Nov 2016, 12:25

@kanu:
Heißt das du verwendest SHA512? Welchen cost Wert hast du? Eine SSD bringt hier nichts. Für die performance ist hier rein die CPU verantwortlich. (Als Vergleich: mein Notebook hat einen Intel i7. Hier brauchts wie gesagt 60sec für cost=20)

@Giovanni9030:
Wart am besten auf die Beta 3. Wird vermutlich dieses Wochenende rauskommen. Dann testen wir das ganze nochmals.
kanu
Beiträge: 58
Registriert: 22. Okt 2009, 17:27
Wohnort: Kiel
Kontaktdaten:

Re: Fehler in passwordhashing.php

Beitragvon kanu » 30. Nov 2016, 23:05

31 hatte ich, habe es dann auf 10 korrigiert. Mit einem i7 kann ich nicht ganz mithalten, es läuft auf einem Allwinner A20 SoC mit ARM-Cortex-A7-CPU. ;)
verwendet Admidio auf rgk.org 8)
XimeX
Developer
Beiträge: 1147
Registriert: 12. Jul 2015, 13:21
Wohnort: Austria

Re: Fehler in passwordhashing.php

Beitragvon XimeX » 3. Dez 2016, 15:30

Ich hoffe das der letzte Fehler jetzt behoben ist. Es wird morgen eine v3.2 Beta 3 geben und vll auch eine v3.1.10
Benutzeravatar
fasse
Administrator
Beiträge: 4837
Registriert: 12. Nov 2005, 16:06

Fehler in passwordhashing.php

Beitragvon fasse » 4. Dez 2016, 20:58

Bitte setzt noch einmal die Testungebung von eurer 3.1 neu auf und führt das Update auf die 3.2 Beta 3 durch. Es sollte jetzt nicht mehr zu den hier geschielderten Problemen kommen.
Offe
Beiträge: 568
Registriert: 30. Aug 2007, 17:42

Re: Fehler in passwordhashing.php

Beitragvon Offe » 4. Dez 2016, 21:05

Soll der Test direkt von 3.1.x (< Version 3.1.10) sein oder zunächst 3.1.x auf 3.1.10 und danach auf 3.2.0 Beta 3 geupdatet werden?

Gruß Offe
Benutzeravatar
fasse
Administrator
Beiträge: 4837
Registriert: 12. Nov 2005, 16:06

Re: Fehler in passwordhashing.php

Beitragvon fasse » 4. Dez 2016, 22:44

Wenns geht direkt von 3.1.x (< 3.1.10).

Viele Grüße
Fasse
Offe
Beiträge: 568
Registriert: 30. Aug 2007, 17:42

Re: Fehler in passwordhashing.php

Beitragvon Offe » 4. Dez 2016, 23:27

also ich habe nun meine Testinstallation auf den Stand von 3.1.9 erstellt und wollte direkt auf 3.2.0 Beta 3 updaten. System_hashing_cost steht vor dem Update auf 31. Wenn ich nun die Files ersetzt habe, erscheint beim Aufruf der Admidio-Installation (noch kein Datenbankupdate passiert) folgender Fehler

PHP Fatal error: Call to a member function info() on null in /var/www/html/adm_program/syste/classes/database.php on line 497


Vielleicht könnte das jemand nochmal verifizieren.

Danke und Gruß
Offe
XimeX
Developer
Beiträge: 1147
Registriert: 12. Jul 2015, 13:21
Wohnort: Austria

Re: Fehler in passwordhashing.php

Beitragvon XimeX » 5. Dez 2016, 21:05

du meinst beim aufruf von update.php oder?
Sieht so aus als wäre das globale $gLogger objekt nicht initialisiert. Ergibt aber keinen Sinn... Steht was im log file? (adm_my_files/logs/admidio.log)
Offe
Beiträge: 568
Registriert: 30. Aug 2007, 17:42

Re: Fehler in passwordhashing.php

Beitragvon Offe » 5. Dez 2016, 22:04

Ich rufe immer das Root-Verzeichnis auf und werde dann auf die Update-Seite weitergeleitet.

Der Fehler tauchte nur im PHP-Errorlog auf, es wurde kein Admidio-Logfile angelegt.

Gruß Offe
XimeX
Developer
Beiträge: 1147
Registriert: 12. Jul 2015, 13:21
Wohnort: Austria

Re: Fehler in passwordhashing.php

Beitragvon XimeX » 9. Dez 2016, 13:07

Also du rufst direkt den root ordner von admidio auf, wirst weitergeleitet auf die adm_program/installation/update.php und dann kommt direkt der Fehler?
Hast du auch den libs ordner akualisiert?
Offe
Beiträge: 568
Registriert: 30. Aug 2007, 17:42

Re: Fehler in passwordhashing.php

Beitragvon Offe » 11. Dez 2016, 12:19

Ich habe den Test nun nochmal langsam Schritt für Schritt durchgeführt. Ein Update von 3.1.9 auf 3.2.0 Beta 3 hat nun funktioniert. system_hashing_cost war zunächst auf 3.1.9 = 31, nach dem Update auf 3.2.0 Beta 3 auf 11, das Update lief durch. Irgendwas scheint da das letzte Mal eventuell beim Hochladen etc. schief gegangen zu sein.

Da mir noch ein zwei Dinge beim Update aufgefallen sind, habe ich dies nun mal in einen extra Thread gepackt viewtopic.php?f=11&t=7281

Gruß Offe
Benutzeravatar
fasse
Administrator
Beiträge: 4837
Registriert: 12. Nov 2005, 16:06

Re: Fehler in passwordhashing.php

Beitragvon fasse » 11. Dez 2016, 21:46

Dann ist dieses Thema ja erledigt.

Zurück zu „Betatests - Archiv“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 4 Gäste