Updatefehler bei Update von 3.2 auf 4.1

Hast du Probleme Admidio einzurichten? Hier kannst du Fragen rund um die Einrichtung stellen.
Benutzeravatar
cortlieb
Beiträge: 10
Registriert: 13. Apr 2022, 08:33

Updatefehler bei Update von 3.2 auf 4.1

Beitrag von cortlieb »

Hallo liebe Leute,

ich habe eine Admidio Installation "geerbt", um die ich mich jetzt kümmern soll.
Der Stand ist so, dass es (vermutlich) eine 3.2.x Installation gibt (kann man die Version eigentlich irgendwo in der Oberfläche sehen, ich habe nichts gefunden), die aber nicht mehr so richtig funktioniert. Die Daten scheinen noch alle da zu sein, grundsätzlich geht auch etwas, die Oberfläche sieht allerdings merkwürdig aus.
admidio_version_3.jpg
admidio_version_3.jpg (154.82 KiB) 486 mal betrachtet

Außerdem in einem anderen Verzeichnis auf dem Server eine wohl nicht zu Ende ausgeführte Installation einer 4.x-Version.

Nun frage ich mich, wie ich am besten vorgehe, um eine lauffähige Admidio Installation in der Version 4.x zu haben, die natürlich die alten Daten wieder beinhaltet.

Ich könnte versuchen, die laufende Version 3.x upzudaten. Nachdem die aber schon ein bisschen verbastelt zu sein scheint, habe ich da Bedenken. Außerdem ist das immerhin eine Installation, die Zugriff auf die Mitgliederdaten ermöglicht.
Alternativ könnte ich eine frische Installation der aktuellen Version durchführen und dann die bestehenden Daten übernehmen. Würden dann die bestehenden Daten auch in die neue Struktur der Version 4.x umgewandelt oder passiert das nur bei einem regelrechten Update?
Welches Vorgehen würdet ihr mir empfehlen?

Vielen Dank im voraus für eure Tipps!

Christian
Benutzeravatar
fasse
Administrator
Beiträge: 5405
Registriert: 12. Nov 2005, 16:06

Re: Update vs. Neuinstallation

Beitrag von fasse »

Hallo Christian,

bei den Oberflächen-Problemen, sieht es eher danach aus, das irgendwo ein Pfad nicht richtig gesetzt ist. Evtl. auch nur eine Umstellung von http auf https nicht richtig umgesetzt. Schau dir dazu mal in adm_my_files/config.php die Varialbe $g_root_path an. Ist die soweit richtig gesetzt ? Auch http vs. https?

Ich würde auf jeden Fall ein Update empfehlen. Auch wenn die Oberfläche sonderbar aussieht, denke ich nicht, dass an der Datenbank gebastelt wurde.

Mache vorher zur Sicherheit ein Backup der Datenbank. Entweder mit phpmyadmin oder mit unserem Modul.

Anschließend solltest du ein Update nach unserer Anleitung angehen können.

Viele Grüße
Fasse
Benutzeravatar
cortlieb
Beiträge: 10
Registriert: 13. Apr 2022, 08:33

Re: Update vs. Neuinstallation

Beitrag von cortlieb »

Vielen Dank für die schnelle Antwort!
Umstellung von http:// nach https:// klingt vielversprechend, der vorige Admin hat von so einer Umstellung berichtet, war aber nicht ganz sicher, ob die Probleme danach aufgetreten sind.
Werde mir das Ganze morgen mal anschauen und das Ergebnis posten.
Benutzeravatar
fasse
Administrator
Beiträge: 5405
Registriert: 12. Nov 2005, 16:06

Re: Update vs. Neuinstallation

Beitrag von fasse »

PS: Die Version sollte in den Einstellungen unter "Systeminformationen" stehen.
Benutzeravatar
cortlieb
Beiträge: 10
Registriert: 13. Apr 2022, 08:33

Re: Update vs. Neuinstallation

Beitrag von cortlieb »

Das hat leider noch nicht so gut geklappt.
Ich habe die $g_root_path angepasst (hatte tatsächlich fälschlicher Weise einen http:// Pfad), das hat aber erst mal nichts geändert. Dann habe ich das Update durchgeführt, wie hier https://www.admidio.org/dokuwiki/doku.p ... _version_4 beschrieben.

Danach geht erst mal gar nichts mehr. Firefox zeigt mir einen "white screen", Chrome sagt:
"Diese Seite funktioniert nicht <domain> kann diese Anfrage momentan nicht verarbeiten.
HTTP ERROR 500"
Habt ihr einen Tipp wo ich anfangen kann zu suchen?
Benutzeravatar
cortlieb
Beiträge: 10
Registriert: 13. Apr 2022, 08:33

Re: Update vs. Neuinstallation

Beitrag von cortlieb »

Hier noch ein paar mehr Fakten:
  • der direkte Aufruf von .../admidio/adm_program/installation/update.php. führt zur Ausgabe von nichts
  • Aufruf von .../admidio/index.php führt zur Ausgabe von nichts
  • ich habe die config.php umbenannt, in der Hoffnung, dass dann ein Installationsskript aufgerufen wird, führt aber auch zu nichts
  • eine kurze Debugausgabe am Anfang der .../admidio/index.php wird ordnungsgemäß ausgegeben
Benutzeravatar
cortlieb
Beiträge: 10
Registriert: 13. Apr 2022, 08:33

Re: Update vs. Neuinstallation

Beitrag von cortlieb »

Noch ein weiteres Update:
nach dem ich .../admidio/config.php und .../admidio/adm_my_files/config.php umbenant habe, lande ich beim Aufruf von .../admidio/index.php bei .../admidio/adm_program/installation/installation.php.
Ich denke, das ist so korrekt, aber es wird weiter nichts ausgegeben.
Benutzeravatar
fasse
Administrator
Beiträge: 5405
Registriert: 12. Nov 2005, 16:06

Re: Update vs. Neuinstallation

Beitrag von fasse »

Hast du Zugriff auf eine phperror-Datei bzw. kannst du sowas bei deinem Hoster einrichten?

Eine weiße Seite ist eigentlich ein Hinweis darauf, dass er intern auf irgendeinen unerwarteten Fehler läuft, welcher dann in einer phperror-Datei ausgegeben wird.

Erstes Ziel sollte es jetzt sein, dass .../admidio/adm_program/installation/update.php zu einer Ausgabe führt.

Die config.php solltest du nicht umbenennen. Wenn es diese nicht gibt, dann ist es erst einmal richtig, dass Admidio eine Neuinstallation machen will.

PS: Hast du auch die index.php im Hauptverzeichnis ausgetauscht?
Benutzeravatar
cortlieb
Beiträge: 10
Registriert: 13. Apr 2022, 08:33

Re: Update vs. Neuinstallation

Beitrag von cortlieb »

So, ich bin ein bisschen weiter gekommen.
Ein Fehler-Log habe ich gefunden. Die Einträge dort konnte ich soweit interpretieren, dass mir eine Datei fehlt. Tatsächlich habe ich dann festgestellt, dass ich offensichtlich die Ordner /modules und /system aus dem Update-Paket nicht mit auf den Server übertragen habe, warum auch immer. Das habe ich nachgeholt und hatte dann tatsächlich eine Anzeige beim Aufruf der Admidio-Seite (die URL zu der ich geleitet wurde war: https://<domain>/admidio/adm_program/installation/update.php?mode=2)

Dort gab es sinngemäß die Info, dass meine Dateien schon upgedated wären, aber meine Datenbank noch nicht. Ich habe den Prozess dann gestartet, der in einem white screen endete. Danach konnte ich mich aber anmelden, allerdings auch nicht viel mehr.

Ich habe dann manuell nochmal https://<domain>/admidio/adm_program/installation/update.php aufgerufen. Wiederum wurde mir das Update der Datenbank angeboten, diesmal von Version 4.1.10 auf 4.1.10. Scheinbar ist das Update vorher also (zumindest teilweise) gelaufen. Diesmal wurde das Update mit einer ordnungsgemäßen Meldung (so etwas wie: Update war erfolgreich) durchgeführt.

Beim Aufruf der Seite bekomme ich einen korrekten Anmeldebildschirm.
Wenn ich mich anmelde bekomme ich zunächst einen white screen und im Errorlog finde ich diese Meldung:

Code: Alles auswählen

181795#0: *6340942 FastCGI sent in stderr: "PHP message: PHP Fatal error: Uncaught Error: Call to a member function fetchColumn() on bool in /var/www/vhosts/salt-n-light.de/httpdocs/saltnl/admidio/adm_program/system/classes/TableMessage.php:166
Stack trace:
#0 /var/www/vhosts/salt-n-light.de/httpdocs/saltnl/admidio/adm_program/system/classes/MenuNode.php(221): TableMessage->countUnreadMessageRecords(98)
#1 /var/www/vhosts/salt-n-light.de/httpdocs/saltnl/admidio/adm_program/system/classes/Menu.php(167): MenuNode->loadFromDatabase(1)
#2 /var/www/vhosts/salt-n-light.de/httpdocs/saltnl/admidio/adm_program/system/classes/Menu.php(133): Menu->loadFromDatabase()
#3 /var/www/vhosts/salt-n-light.de/httpdocs/saltnl/admidio/adm_program/system/classes/HtmlPage.php(447): Menu->getHtml()
#4 /var/www/vhosts/salt-n-light.de/httpdocs/saltnl/admidio/adm_program/overview.php(29): HtmlPage->show()
#5 {main}
thrown in /var/www/vhosts/salt-n-light.de/httpdocs/saltnl/admidio/adm_program/system/classes/TableMessage.php on line 166" while reading response header from upstream
Nach einem einfachen Refresh der Seite wird dann aber ein (so weit ich das beurteilen kann) korrekter Übersichtsbildschirm angezeigt.
Einen Fehler gibt es aber trotzdem:

Code: Alles auswählen

181793#0: *6341164 FastCGI sent in stderr: "PHP message: PHP Fatal error: Uncaught Error: Call to a member function rowCount() on bool in /var/www/vhosts/salt-n-light.de/httpdocs/saltnl/admidio/adm_plugins/birthday/birthday.php:227
Stack trace:
#0 /var/www/vhosts/salt-n-light.de/httpdocs/saltnl/admidio/adm_program/system/smarty-plugins/function.load_admidio_plugin.php(44): require()
#1 /var/www/vhosts/salt-n-light.de/httpdocs/saltnl/admidio/adm_my_files/templates/compile/1bddab03effaaf5fc4af1c6148b241a60ad42c33_0.file.overview.tpl.php(39): smarty_function_load_admidio_plugin(Array, Object(Smarty_Internal_Template))
#2 /var/www/vhosts/salt-n-light.de/httpdocs/saltnl/admidio/adm_program/libs/server/smarty/smarty/libs/sysplugins/smarty_template_resource_base.php(123): content_626f8096740e40_75134442(Object(Smarty_Internal_Template))
#3 /var/www/vhosts/salt-n-light.de/httpdocs/saltnl/admidio/adm_program/libs/server/smarty/smarty/libs/sysplugins/smarty_template_compiled.php(114): Smarty_Template_Resource_Base->getRenderedTemplateCode(Object(Smarty_Inte" while reading response header from upstream
Von diesem Anmeldebildschirm komme ich aber nirgendwo hin.
Aufruf von "Ankündigungen" führt zu einem white screen mit dieser Fehlermeldung:

Code: Alles auswählen

	181792#0: *6342126 FastCGI sent in stderr: "PHP message: PHP Fatal error: Uncaught Error: Call to a member function rowCount() on bool in /var/www/vhosts/salt-n-light.de/httpdocs/saltnl/admidio/adm_program/system/classes/HtmlForm.php:1633
Stack trace:
#0 /var/www/vhosts/salt-n-light.de/httpdocs/saltnl/admidio/adm_program/modules/announcements/announcements.php(125): HtmlForm->addSelectBoxForCategories('cat_uuid', 'Kategorie', Object(Database), 'ANN', 'FILTER_CATEGORI...', Array)
#1 {main}
thrown in /var/www/vhosts/salt-n-light.de/httpdocs/saltnl/admidio/adm_program/system/classes/HtmlForm.php on line 1633" while reading response header from upstream
Der Link "Dokumente und Dateien" führt zu einem "404 Not found" Bildschirm, Fehlermeldung ist:

Code: Alles auswählen

181795#0: *6342419 FastCGI sent in stderr: "PHP message: PHP Fatal error: Uncaught Error: Call to a member function rowCount() on bool in /var/www/vhosts/salt-n-light.de/httpdocs/saltnl/admidio/adm_plugins/birthday/birthday.php:227
Stack trace:
#0 /var/www/vhosts/salt-n-light.de/httpdocs/saltnl/admidio/adm_program/system/smarty-plugins/function.load_admidio_plugin.php(44): require()
#1 /var/www/vhosts/salt-n-light.de/httpdocs/saltnl/admidio/adm_my_files/templates/compile/1bddab03effaaf5fc4af1c6148b241a60ad42c33_0.file.overview.tpl.php(39): smarty_function_load_admidio_plugin(Array, Object(Smarty_Internal_Template))
#2 /var/www/vhosts/salt-n-light.de/httpdocs/saltnl/admidio/adm_program/libs/server/smarty/smarty/libs/sysplugins/smarty_template_resource_base.php(123): content_626f8096740e40_75134442(Object(Smarty_Internal_Template))
#3 /var/www/vhosts/salt-n-light.de/httpdocs/saltnl/admidio/adm_program/libs/server/smarty/smarty/libs/sysplugins/smarty_template_compiled.php(114): Smarty_Template_Resource_Base->getRenderedTemplateCode(Object(Smarty_Inte" while reading response header from upstream
Die Fehlermeldung sehen mir wie Probleme mit Eintragungen in der Datenbank aus.
Ich kann auch in der Übersicht keine Mitgliedsdaten sehen.
Hier wird es aber für mich schwierig, die Meldungen zu interpretieren.
Aber zum Glück gibt es hier ja Experten. :)

Mir ist noch aufgefallen, dass es im /admidio-Ordner keine config.php mehr gibt. Die war vor dem Update sicher da, da ich sie zunächst umbenannt hatte (um evtl. eine Neuinstallation zu provozieren) und vor dem Update wieder zurück benannt hatte.
Außerdem gab es keine Meldung zu einem Update der Applikation als solcher. Nur die Meldung (s.o.), dass die Dateien bereits upgedated seinen und die Datenbank angepasst werden muss. Vielleicht ist das so normal, vielleicht aber auch ein Hinweis auf mögliche Probleme.

Die Links "Mein Profil" und "Abmelden" funktionieren.
Benutzeravatar
fasse
Administrator
Beiträge: 5405
Registriert: 12. Nov 2005, 16:06

Re: Update vs. Neuinstallation

Beitrag von fasse »

Puh, das ist aber alles sehr sonderbar. Die ganzen Fehler kommen daher, dass Admidio irgendwie Probleme mit der Datenbank hat.

Die config.php ist mittlerweile umgezogen nach admidio/adm_my_files/config.php.

Hast du Zugriff auf die Datenbank?
Wenn ja dann schau dort doch mal bitte in die Tabelle adm_components und dort in die Zeile mit com_name = "Admidio Core". Was steht dort dann bei com_version und com_update_step ?
Benutzeravatar
cortlieb
Beiträge: 10
Registriert: 13. Apr 2022, 08:33

Re: Update vs. Neuinstallation

Beitrag von cortlieb »

Vielen Dank für die super-schnelle Antwort!

Ok, unter admidio/adm_my_files/ habe ich eine config.php, Daten sehen für mich auch vernünftig aus.

com_version: 4.1.10
com_update_step: 1030
Benutzeravatar
cortlieb
Beiträge: 10
Registriert: 13. Apr 2022, 08:33

Re: Update vs. Neuinstallation

Beitrag von cortlieb »

Hallo liebe Leute,
habt ihr noch einen Tipp für mich?
Helfen die Versionsangaben aus der Datenbank (s. meinen vorigen Post) irgendwie weiter?
Benutzeravatar
fasse
Administrator
Beiträge: 5405
Registriert: 12. Nov 2005, 16:06

Re: Update vs. Neuinstallation

Beitrag von fasse »

Das Update scheint wirklich erfolgreich durchgelaufen zu sein.

Aber scheinbar gibt es Probleme bei deiner Datenbank, sobald wir dort irgendwas mit der Anzahl von Datensätzen ermitteln. Das verstehe ich nicht so ganz. Solche Probleme hatte bisher noch keiner.
Benutzeravatar
cortlieb
Beiträge: 10
Registriert: 13. Apr 2022, 08:33

Re: Update vs. Neuinstallation

Beitrag von cortlieb »

OK, verstehe, schwieriger Fall!
Hast du einen Hinweis, wie ich da weiter kommen kann?

Ich könnte das Ganze mit einem Entwickler weiter debuggen (alleine ist es für mich sicherlich etwas schwierig), falls das für euch von grundsätzlichem Interesse ist.

Ansonsten doch eine neue Installation und dann die alte Datenbank verwenden? In der Hoffnung, dass dann nach einer erneuten automatischen Migration der Datenbank ins neue Format weniger Probleme auftreten?

Über einen Tipp wäre ich dankbar!
Benutzeravatar
fasse
Administrator
Beiträge: 5405
Registriert: 12. Nov 2005, 16:06

Re: Update vs. Neuinstallation

Beitrag von fasse »

Kannst du mal den Debug-Modus kurzzeitig einschalten und dann die Ankündigungen aufrufen. Anschließend sollte unter adm_my_files/logs eine Datei angelegt worden sein. Diese kannst du mir dann mal gerne an die E-Mail-Adresse im Impressum zuschicken.
Antworten